Показано с 1 по 3 из 3.

Тема: Есть кто по Cisco? Проблемы с EIGRP на споке

  1. #1
    Регистрация
    16.12.2006
    Сообщений
    340

    По умолчанию Есть кто по Cisco? Проблемы с EIGRP на споке

    Приветствую.

    Изначально хотел сделать для каждого провайдера свой VRF. Два VRF не удалось сделать из-за того, что один из провайдеров использует подключение по pppoe. Поэтому сделал только один VRF. Оба туннеля устанавливаются, но EIGRP ведет себя не так, как хотелось.

    Делаю так. Отключаю все туннели "sh", включаю Tunnel0 "no sh" происходит обмен EIGRP с соседями - все отлично. Включаю Tunnel1 "no sh" происходит обмен EIGRP с соседями, но тут же появляется сообщение "%DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 10.1.123.1 (Tunnel0) is down: holding time expired". Занавес.

    Вопрос: почему и что делать?

    Конфиг спока с вышеописанной проблемой (убрал лишние строки):

    !
    vrf definition ISP2
    rd 2:2
    !
    address-family ipv4
    exit-address-family
    !
    enable secret 5
    !
    !
    !
    license udi pid CISCO1812-J/K9 sn FHK130825QK
    username admin password 0
    !
    !
    crypto ikev2 diagnose error 50
    !
    !
    !
    crypto keyring ISP2 vrf ISP2
    pre-shared-key address 82.xx.xx.22 key 444444444444444444444444
    !
    crypto isakmp policy 1
    encr aes 256
    hash md5
    authentication pre-share
    group 14
    !
    crypto isakmp policy 10
    hash md5
    authentication pre-share
    crypto isakmp key 456777777777 address 31.yy.yy.205
    !
    !
    crypto ipsec transform-set TRANS_SET esp-aes 256 esp-md5-hmac
    mode transport
    !
    crypto ipsec profile IPSEC_PROF
    set transform-set TRANS_SET
    !
    !
    !
    !
    !
    !
    interface Tunnel0
    description ***PRIMARY DMVPN CLOUD***
    bandwidth 1000
    ip address 10.1.123.2 255.255.255.224
    no ip redirects
    ip mtu 1400
    ip nhrp authentication cisco
    ip nhrp map 10.1.123.1 31.yy.yy.205
    ip nhrp map multicast 31.yy.yy.205
    ip nhrp network-id 1
    ip nhrp holdtime 360
    ip nhrp nhs 10.1.123.1
    ip tcp adjust-mss 1360
    tunnel source Dialer1
    tunnel mode gre multipoint
    tunnel key 1
    tunnel protection ipsec profile IPSEC_PROF shared
    !
    interface Tunnel1
    description ***BACKUP DMVPN CLOUD***
    bandwidth 1000
    ip address 10.2.123.2 255.255.255.224
    no ip redirects
    ip mtu 1440
    ip nhrp authentication cisco
    ip nhrp map 10.2.123.1 82.xx.xx.22
    ip nhrp map multicast 82.xx.xx.22
    ip nhrp network-id 2
    ip nhrp holdtime 370
    ip nhrp nhs 10.2.123.1
    ip tcp adjust-mss 1393
    tunnel source FastEthernet0
    tunnel mode gre multipoint
    tunnel key 2
    tunnel vrf ISP2
    tunnel protection ipsec profile IPSEC_PROF shared
    !
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface FastEthernet0
    vrf forwarding ISP2
    ip address 172.16.113.26 255.255.255.252
    no ip redirects
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    no cdp enable
    !
    interface FastEthernet1
    description ROSTELECOM
    no ip address
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    !
    interface FastEthernet2
    speed 10
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    !
    interface FastEthernet5
    !
    interface FastEthernet6
    !
    interface FastEthernet7
    !
    interface FastEthernet8
    !
    interface FastEthernet9
    !
    interface Vlan1
    ip address 192.168.6.1 255.255.255.0
    ip nat inside
    no ip virtual-reassembly
    !
    interface Dialer1
    description ROSTELECOM
    mtu 1492
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    ppp authentication chap callin
    ppp chap hostname
    ppp chap password 0
    ppp ipcp dns request
    !
    !
    router eigrp 1
    network 10.1.123.0 0.0.0.31
    network 192.168.6.0
    !
    !
    router eigrp 2
    network 10.2.123.0 0.0.0.31
    network 192.168.6.0
    !
    router nhrp
    !
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route vrf ISP2 0.0.0.0 0.0.0.0 172.16.113.25

  2. #2
    Регистрация
    08.04.2013
    Сообщений
    5,176

    По умолчанию

    Цитата Сообщение от E-Motion Посмотреть сообщение
    Изначально хотел сделать для каждого провайдера свой VRF. Два VRF не удалось сделать из-за того, что один из провайдеров использует подключение по pppoe.
    pppoe не должно быть помехой для vrf. Никогда не встречал проблем с этим.

    На интерфейсах
    FastEthernet1 и Dialer1 можно дать команду
    ip vrf forwarding ISP1
    ну и маршрут исправить
    ip route vrf ISP1 0.0.0.0 0.0.0.0 Dialer1


    Делаю так. Отключаю все туннели "sh", включаю Tunnel0 "no sh" происходит обмен EIGRP с соседями - все отлично. Включаю Tunnel1 "no sh" происходит обмен EIGRP с соседями, но тут же появляется сообщение "%DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 10.1.123.1 (Tunnel0) is down: holding time expired". Занавес.
    Надо смотреть debug, желательно сразу на двух маршрутизаторах, и искать почему истекло время ожидания (holding time expired).

  3. #3
    Регистрация
    24.07.2016
    Сообщений
    2,516

    По умолчанию

    Понапокупают себе кисок для понтов, а потом жалуются, что настроить не могут!

Ваши права в разделе

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •